# Troubleshooting DRAGEN single cell RNA App UMI error in BaseSpace

When running the DRAGEN Single Cell RNA (scRNA) pipeline v4.4.4 on BaseSpace (BSSH) with the Illumina Single Cell 3' RNA library prep kit, using a FASTQ file that does not have the UMI sequence in their FASTQ header will prevent proper cell barcode and UMI parsing, leading to a failed analysis.

**Symptoms**

Example dragen\_run log reports error:

Assertion failed in ../src/host/dragen\_api/umi/umi\_parser.cpp line 690 -- umiSection -- Read-name has fewer than 8 sections: VH00284:510:AACJNNCHV:1:1101:64888:1151

umiSection -- Read-name has fewer than 8 sections: VH00284:510:AACJNNCHV:1:1101:64888:1151

This error can happen \~45 minutes into the analysis, and will stop the analysis.

Example of a correct FASTQ header with UMI:

@VH00284:510:AACJNNCHV:1:1101:64888:1151:AGAGGAGTGATGGATGAAGAGTGGGTTTCGAGACAAAGAGTTCAC

The sequence starting with AGA is the barcode+UMI read

**Cause**

UMIs (Unique Molecular Identifiers) must be properly specified and passed during demultiplexing and FASTQ generation.

Common causes of UMI absence include:

1. UMIs not specified in the Sample Sheet during bcl2fastq or BCL Convert.
2. FASTQs generated with a tool that does not preserve UMI information in read headers.

**Resolution**

Option 1: Change the following settings in the pipeline:

* Barcode/UMI Read: Read 1
* Barcode/UMI Source: Barcode/UMI Read

This will pull the UMI information directly from Read 1 and allow the pipeline to bin the reads appropriately.

Option 2: create FASTQ files with the UMIs in the headers by requeuing the FASTQ file generation, specifying the correct Barcode/UMI Source: FASTQ Header. (More details on generating the FASTQ files is available [**here**](https://help.dragen.illumina.com/product-guide/dragen-v4.4/dragen-single-cell-pipeline/dragen-scrna)). Then, repeat the analysis with the correct FASTQ files.

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| *For any feedback or questions regarding this article (Illumina Knowledge Article #9852), contact Illumina Technical Support* [*techsupport@illumina.com*](mailto:techsupport@illumina.com?subject=Question%2FFeedback%20Regarding%20Illumina%20Knowledge%20Article%20#000009852%20-%20Software%20\&body=Dear%20Illumina%20Technical%20Support,%0D%0A%0D%0A)*.* |


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